Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About CBOR Encoded X.509 (C509) Created 2026-08-11 Last Updated 2026-10-06 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • C509 Certificate Types • C509 Certification Request Types • C509 Private Key Types • C509 Certification Request Templates Types • C509 RDN Attributes • C509 CR Attributes • C509 Extensions • C509 Certificate Policies • C509 Policies Qualifiers • C509 Information Access • C509 Extended Key Usages • C509 General Names • C509 Signature Algorithms • C509 Public Key Algorithms C509 Certificate Types Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Description Reference -32768 to -1 Unassigned 0 Reserved [RFC-ietf-cose-cbor-encoded-cert-21] 1 Reserved [RFC-ietf-cose-cbor-encoded-cert-21] 2 Natively Signed C509 Certificate [RFC-ietf-cose-cbor-encoded-cert-21] 3 CBOR Re-encoded X.509 v3 Certificate [RFC-ietf-cose-cbor-encoded-cert-21] 4-32767 Unassigned C509 Certification Request Types Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Description Reference -32768 to -1 Unassigned 0 Reserved [RFC-ietf-cose-cbor-encoded-cert-21] 1 Reserved [RFC-ietf-cose-cbor-encoded-cert-21] 2 Natively Signed C509 Certification Request [RFC-ietf-cose-cbor-encoded-cert-21] 3 CBOR re-encoding of RFC 2986 certification request [RFC-ietf-cose-cbor-encoded-cert-21] 4-32767 Unassigned C509 Private Key Types Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Comments subjectPrivateKey Reference -32768 to -1 Unassigned 0 Asymmetric Key Package [RFC 5958] PrivateKey OCTET STRING encoded as CBOR byte string [RFC-ietf-cose-cbor-encoded-cert-21] 1 COSE Key Object [RFC 9052] COSE_Key containing a private key [RFC-ietf-cose-cbor-encoded-cert-21] 2 to 32767 Unassigned C509 Certification Request Templates Types Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Description Reference -32768 to -1 Unassigned 0 Simple C509 Certification Request Template [RFC-ietf-cose-cbor-encoded-cert-21] 1-32767 Unassigned C509 RDN Attributes Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures 0 - 23 IETF Review with Expert Review 24 - 32767 Expert Review 32768 - 65535 Reserved for Private Use 65536 - 9223372036854775807 Reserved for Future Use Value Name Identifiers OID DER Comments Reference 06 09 2A 86 48 0 Email Address emailAddress, e-mailAddress 1.2.840.113549.1.9.1 86 [RFC 2985] [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 09 01 06 03 1 Common Name commonName, cn 2.5.4.3 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 03 06 03 2 Surname surname, sn 2.5.4.4 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 04 06 03 3 Serial Number serialNumber 2.5.4.5 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 05 06 03 4 Country countryName, c 2.5.4.6 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 06 06 03 5 Locality localityName, locality, l 2.5.4.7 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 07 06 State or 03 6 Province stateOrProvinceName, st 2.5.4.8 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 08 06 03 7 Street Address streetAddress, street 2.5.4.9 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 09 06 03 8 Organization organizationName, o 2.5.4.10 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 0A 06 Organizational 03 9 Unit organizationalUnitName, ou 2.5.4.11 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 0B 06 03 10 Title title 2.5.4.12 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 0C 06 Business 03 11 Category businessCategory 2.5.4.15 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 0F 06 03 12 Postal Code postalCode 2.5.4.17 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 11 06 03 13 Given Name givenName 2.5.4.42 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 2A 06 03 14 Initials initials 2.5.4.43 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 2B 06 Generation 03 15 Qualifier generationQualifier 2.5.4.44 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 2C 06 03 16 DN Qualifier dnQualifier 2.5.4.46 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 2E 06 03 17 Pseudonym pseudonym 2.5.4.65 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 41 06 Organization 03 18 Identifier organizationIdentifier 2.5.4.97 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 61 06 0B 2B 06 01 Jurisdiction 04 Proprietary 19 Locality Name jurisdictionLocalityName 1.3.6.1.4.1.311.60.2.1.1 01 Microsoft [RFC-ietf-cose-cbor-encoded-cert-21] 82 Attribute 37 3C 02 01 01 06 0B 2B 06 01 Jurisdiction 04 Proprietary 20 State or jurisdictionStateOrProvinceName 1.3.6.1.4.1.311.60.2.1.2 01 Microsoft [RFC-ietf-cose-cbor-encoded-cert-21] Province 82 Attribute 37 3C 02 01 02 06 0B 2B 06 01 Jurisdiction 04 Proprietary 21 Country Name jurisdictionCountryName 1.3.6.1.4.1.311.60.2.1.3 01 Microsoft [RFC-ietf-cose-cbor-encoded-cert-21] 82 Attribute 37 3C 02 01 03 06 0A 09 92 26 22 Domain domainComponent, dc 0.9.2342.19200300.100.1.25 89 [RFC 4524] [RFC-ietf-cose-cbor-encoded-cert-21] Component 93 F2 2C 64 01 19 23-24 Unassigned 06 03 25 Name name 2.5.4.41 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 29 06 Telephone 03 26 Number telephoneNumber 2.5.4.20 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] 04 14 06 Directory 03 27 Management dmdName 2.5.4.54 55 X.520 [RFC-ietf-cose-cbor-encoded-cert-21] Domain Name 04 36 06 0A 09 92 26 28 userid uid 0.9.2342.19200300.100.1.1 89 [RFC 4524] [RFC-ietf-cose-cbor-encoded-cert-21] 93 F2 2C 64 01 01 06 09 2A 86 Unstructured 48 29 Name unstructuredName 1.2.840.113549.1.9.2 86 [RFC 2985] [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 09 02 06 09 2A 86 Unstructured 48 30 Address unstructuredAddress 1.2.840.113549.1.9.8 86 [RFC 2985] [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 09 08 31-32767 Unassigned 32768-65535 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Private Use 65536-9223372036854775807 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Future Use C509 CR Attributes Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -9223372036854775808 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review 32768-65535 Reserved for Private Use 32768-9223372036854775807 Reserved for Future Use Value Name Identifiers OID DER Comments attributeValue Reference -9223372036854775808 to Unassigned -1 06 09 2A 86 Extension 48 [RFC 0 Request extensionRequest 1.2.840.113549.1.9.14 86 2985] Extensions [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 09 0E 06 09 2A 86 Challenge 48 [RFC 1 Password challengePassword 1.2.840.113549.1.9.7 86 2985] ChallengePassword [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 09 07 06 0A 2B 06 Private 01 2 Key privateKeyPossessionStatement 1.3.6.1.4.1.22112.2.1 04 [RFC PrivateKeyPossessionStatement [RFC-ietf-cose-cbor-encoded-cert-21] Possession 01 9883] Statement 81 AC 60 02 01 3-32767 Unassigned Reserved 32767-65535 for [RFC-ietf-cose-cbor-encoded-cert-21] Private Use Reserved 65536-9223372036854775807 for Future [RFC-ietf-cose-cbor-encoded-cert-21] Use C509 Extensions Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures 1 - 23 IETF Review with Expert Review 24 - 32767 Expert Review 32768 - 65535 Reserved for Private Use 65536 - 9223372036854775807 Reserved for Future Use Value Name Identifiers OID DER Comments extensionValue Reference 06 Subject Key 03 [RFC 1 Identifier subjectKeyIdentifier 2.5.29.14 55 5280] SubjectKeyIdentifier [RFC-ietf-cose-cbor-encoded-cert-21] 1D 0E 06 03 [RFC 2 Key Usage keyUsage 2.5.29.15 55 5280] KeyUsage [RFC-ietf-cose-cbor-encoded-cert-21] 1D 0F 06 Subject 03 [RFC 3 Alternative subjectAltName 2.5.29.17 55 5280] SubjectAltName [RFC-ietf-cose-cbor-encoded-cert-21] Name 1D 11 06 Basic 03 [RFC 4 Constraints basicConstraints 2.5.29.19 55 5280] BasicConstraints [RFC-ietf-cose-cbor-encoded-cert-21] 1D 13 06 CRL 03 [RFC 5 Distribution cRLDistributionPoints 2.5.29.31 55 5280] CRLDistributionPoints [RFC-ietf-cose-cbor-encoded-cert-21] Points 1D 1F 06 Certificate 03 [RFC 6 Policies certificatePolicies 2.5.29.32 55 5280] CertificatePolicies [RFC-ietf-cose-cbor-encoded-cert-21] 1D 20 06 Authority 03 [RFC 7 Key authorityKeyIdentifier 2.5.29.35 55 5280] AuthorityKeyIdentifier [RFC-ietf-cose-cbor-encoded-cert-21] Identifier 1D 23 06 Extended Key 03 [RFC 8 Usage extKeyUsage 2.5.29.37 55 5280] ExtKeyUsageSyntax [RFC-ietf-cose-cbor-encoded-cert-21] 1D 25 06 08 2B Authority 06 9 Information authorityInfoAccess 1.3.6.1.5.5.7.1.1 01 [RFC AuthorityInfoAccessSyntax [RFC-ietf-cose-cbor-encoded-cert-21] Access 05 5280] 05 07 01 01 10-24 Unassigned 06 Issuer 03 [RFC 25 Alternative issuerAltName 2.5.29.18 55 5280] IssuerAltName [RFC-ietf-cose-cbor-encoded-cert-21] Name 1D 12 06 Name 03 [RFC 26 Constraints nameConstraints 2.5.29.30 55 9549] NameConstraints [RFC-ietf-cose-cbor-encoded-cert-21] 1D 1E 06 Policy 03 [RFC 27 Mappings policyMappings 2.5.29.33 55 5280] PolicyMappings [RFC-ietf-cose-cbor-encoded-cert-21] 1D 21 06 Policy 03 [RFC 28 Constraints policyConstraints 2.5.29.36 55 5280] PolicyConstraints [RFC-ietf-cose-cbor-encoded-cert-21] 1D 24 06 03 [RFC 29 Freshest CRL freshestCRL 2.5.29.46 55 5280] FreshestCRL [RFC-ietf-cose-cbor-encoded-cert-21] 1D 2E 06 Inhibit 03 [RFC 30 anyPolicy inhibitAnyPolicy 2.5.29.54 55 5280] InhibitAnyPolicy [RFC-ietf-cose-cbor-encoded-cert-21] 1D 36 06 08 2B Subject 06 31 Information subjectInfoAccess 1.3.6.1.5.5.7.1.11 01 [RFC SubjectInfoAccessSyntax [RFC-ietf-cose-cbor-encoded-cert-21] Access 05 5280] 05 07 01 0B 06 08 2B 06 32 IPAddrBlocks id-pe-ipAddrBlocks 1.3.6.1.5.5.7.1.7 01 [RFC IPAddrBlocks [RFC-ietf-cose-cbor-encoded-cert-21] 05 3779] 05 07 01 07 06 08 2B 06 33 AS id-pe-autonomousSysIds 1.3.6.1.5.5.7.1.8 01 [RFC ASIdentifiers [RFC-ietf-cose-cbor-encoded-cert-21] Identifiers 05 3779] 05 07 01 08 06 08 2B 06 34 IPAddrBlocks id-pe-ipAddrBlocks-v2 1.3.6.1.5.5.7.1.28 01 [RFC IPAddrBlocks [RFC-ietf-cose-cbor-encoded-cert-21] v2 05 8360] 05 07 01 1C 06 08 2B AS 06 35 Identifiers id-pe-autonomousSysIds-v2 1.3.6.1.5.5.7.1.29 01 [RFC ASIdentifiers [RFC-ietf-cose-cbor-encoded-cert-21] v2 05 8360] 05 07 01 1D 06 09 2B 06 OCSP No 01 [RFC 36 Check id-pkix-ocsp-nocheck 1.3.6.1.5.5.7.48.1.5 05 6960] null [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 30 01 05 37 Unassigned 06 08 2B 06 38 TLS Features id-pe-tlsfeature 1.3.6.1.5.5.7.1.24 01 [RFC TLSFeatures [RFC-ietf-cose-cbor-encoded-cert-21] 05 7633] 05 07 01 18 39-32767 Unassigned 32768-65535 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Private Use 65536-9223372036854775807 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Future Use C509 Certificate Policies Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -9223372036854775808 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review 32768-65535 Reserved for Private Use 65536-9223372036854775807 Reserved for Future Use Value Name Identifiers OID DER Comments Reference -9223372036854775808 to -1 Unassigned 06 04 0 Any Policy anyPolicy 2.5.29.32.0 55 1D [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 20 00 06 06 1 Domain Validation domain-validated 2.23.140.1.2.1 67 81 CA/Browser [RFC-ietf-cose-cbor-encoded-cert-21] (DV) 0C 01 Forum 02 01 06 06 2 Organization organization-validated 2.23.140.1.2.2 67 81 CA/Browser [RFC-ietf-cose-cbor-encoded-cert-21] Validation (OV) 0C 01 Forum 02 02 06 06 3 Individual individual-validated 2.23.140.1.2.3 67 81 CA/Browser [RFC-ietf-cose-cbor-encoded-cert-21] Validation (IV) 0C 01 Forum 02 03 06 05 4 Extended ev-guidelines 2.23.140.1.1 67 81 CA/Browser [RFC-ietf-cose-cbor-encoded-cert-21] Validation (EV) 0C 01 Forum 01 5-6 Unassigned 06 08 Resource PKI 2B 06 7 (RPKI) id-cp-ipAddr-asNumber 1.3.6.1.5.5.7.14.2 01 05 [RFC 3779] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 0E 02 06 08 Resource PKI 2B 06 8 (RPKI) id-cp-ipAddr-asNumber-v2 1.3.6.1.5.5.7.14.3 01 05 [RFC 8360] [RFC-ietf-cose-cbor-encoded-cert-21] (Alternative) 05 07 0E 03 9-23 Unassigned 06 07 Remote SIM 67 81 24 Provisioning Role id-rspRole-ci 2.23.146.1.2.1.0 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] Certificate Issuer 02 01 00 06 07 Remote SIM 67 81 25 Provisioning Role id-rspRole-euicc-v2 2.23.146.1.2.1.1 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] eUICC v2 02 01 01 06 0B 67 81 Remote SIM 12 01 26 Provisioning Role id-rspRole-euicc 2.23.146.1.2.1.0.0.0.0.0 02 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] eUICC 00 00 00 00 00 Remote SIM 06 07 Provisioning Role 67 81 27 eUICC Manufacturer id-rspRole-eum-v2 2.23.146.1.2.1.2 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] v2 02 01 02 06 09 Remote SIM 67 81 28 Provisioning Role id-rspRole-eum 2.23.146.1.2.1.0.0.0 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] eUICC Manufacturer 02 01 00 00 00 06 07 Remote SIM 67 81 29 Provisioning Role id-rspRole-dp-tls-v2 2.23.146.1.2.1.3 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DP+ TLS v2 02 01 03 06 0A Remote SIM 67 81 30 Provisioning Role id-rspRole-dp-tls 2.23.146.1.2.1.0.0.1.0 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DP+ TLS 02 01 00 00 01 00 Remote SIM 06 07 Provisioning Role 67 81 31 SM-DP+ id-rspRole-dp-auth-v2 2.23.146.1.2.1.4 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] Authentication v2 02 01 04 06 0A Remote SIM 67 81 32 Provisioning Role id-rspRole-dp-auth 2.23.146.1.2.1.0.0.1.1 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DP+ 02 01 Authentication 00 00 01 01 Remote SIM 06 07 Provisioning Role 67 81 33 SM-DP+ Profile id-rspRole-dp-pb-v2 2.23.146.1.2.1.5 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] Binding v2 02 01 05 06 0A Remote SIM 67 81 34 Provisioning Role id-rspRole-dp-pb 2.23.146.1.2.1.0.0.1.2 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DP+ Profile 02 01 Binding 00 00 01 02 06 07 Remote SIM 67 81 35 Provisioning Role id-rspRole-ds-tls-v2 2.23.146.1.2.1.6 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DS TLS v2 02 01 06 06 0A Remote SIM 67 81 36 Provisioning Role id-rspRole-ds-tls 2.23.146.1.2.1.0.0.2.0 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DS TLS 02 01 00 00 02 00 Remote SIM 06 07 Provisioning Role 67 81 37 SM-DS id-rspRole-ds-auth-v2 2.23.146.1.2.1.7 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] Authentication v2 02 01 07 06 0A Remote SIM 67 81 38 Provisioning Role id-rspRole-ds-auth 2.23.146.1.2.1.0.0.2.1 12 01 GSMA SGP.22 [RFC-ietf-cose-cbor-encoded-cert-21] SM-DS 02 01 Authentication 00 00 02 01 39-32767 Unassigned 32768-65535 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Private Use 65536-9223372036854775807 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Future Use C509 Policies Qualifiers Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Name Identifiers OID DER Comments Reference -32768 to 0 Unassigned 1 Certification Practice id-qt-cps, cps 1.3.6.1.5.5.7.2.1 06 08 2B 06 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] Statement 05 07 02 01 2 User Notice id-qt-unotice, unotice 1.3.6.1.5.5.7.2.2 06 08 2B 06 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 02 02 3-32767 Unassigned C509 Information Access Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Name Identifiers OID DER Comments Reference -32768 to 0 Unassigned 1 OCSP id-ad-ocsp, id-pkix-ocsp 1.3.6.1.5.5.7.48.1 06 08 2B 06 01 05 05 07 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 30 01 2 CA Issuers id-ad-caIssuers, caIssuers 1.3.6.1.5.5.7.48.2 06 08 2B 06 01 05 05 07 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 30 02 3 Time Stamping id-ad-timeStamping, timeStamping 1.3.6.1.5.5.7.48.3 06 08 2B 06 01 05 05 07 [RFC 3161] [RFC-ietf-cose-cbor-encoded-cert-21] 30 03 4 Unassigned 5 CA Repository id-ad-caRepository 1.3.6.1.5.5.7.48.5 06 08 2B 06 01 05 05 07 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 30 05 6-9 Unassigned 10 RPKI Manifest id-ad-rpkiManifest 1.3.6.1.5.5.7.48.10 06 08 2B 06 01 05 05 07 [RFC 6487] [RFC-ietf-cose-cbor-encoded-cert-21] 30 0A 11 Signed Object id-ad-signedObject 1.3.6.1.5.5.7.48.11 06 08 2B 06 01 05 05 07 [RFC 6487] [RFC-ietf-cose-cbor-encoded-cert-21] 30 0B 12 Unassigned 13 RPKI Notify id-ad-rpkiNotify 1.3.6.1.5.5.7.48.13 06 08 2B 06 01 05 05 07 [RFC 8182] [RFC-ietf-cose-cbor-encoded-cert-21] 30 0D 14-32767 Unassigned C509 Extended Key Usages Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -9223372036854775808 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review 32768-65535 Reserved for Private Use 65536-9223372036854775807 Reserved for Future Use Value Name Identifiers OID DER Comments Reference -9223372036854775808 to -1 Unassigned Any Extended Key 06 04 0 Usage anyExtendedKeyUsage 2.5.29.37.0 55 1D [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 25 00 06 08 TLS Server 2B 06 1 authentication id-kp-serverAuth 1.3.6.1.5.5.7.3.1 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 01 06 08 TLS Client 2B 06 2 Authentication id-kp-clientAuth 1.3.6.1.5.5.7.3.2 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 02 06 08 2B 06 3 Code Signing id-kp-codeSigning 1.3.6.1.5.5.7.3.3 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 03 06 08 Email protection 2B 06 4 (S/MIME) id-kp-emailProtection 1.3.6.1.5.5.7.3.4 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 04 5-7 Unassigned 06 08 id-kp-timeStamping, 2B 06 8 Time Stamping timestamping 1.3.6.1.5.5.7.3.8 01 05 [RFC 3161] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 08 06 08 2B 06 9 OCSP Signing id-kp-OCSPSigning 1.3.6.1.5.5.7.3.9 01 05 [RFC 5280] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 09 06 07 Kerberos PKINIT 2B 06 10 Client Auth id-pkinit-KPClientAuth 1.3.6.1.5.2.3.4 01 05 [RFC 4556] [RFC-ietf-cose-cbor-encoded-cert-21] 02 03 04 06 07 2B 06 11 Kerberos PKINIT KDC id-pkinit-KPKdc 1.3.6.1.5.2.3.5 01 05 [RFC 4556] [RFC-ietf-cose-cbor-encoded-cert-21] 02 03 05 06 08 2B 06 12 SSH Client id-kp-secureShellClient 1.3.6.1.5.5.7.3.21 01 05 [RFC 6187] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 15 06 08 2B 06 13 SSH Server id-kp-secureShellServer 1.3.6.1.5.5.7.3.22 01 05 [RFC 6187] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 16 06 08 2B 06 14 Bundle Security id-kp-bundleSecurity 1.3.6.1.5.5.7.3.35 01 05 [RFC 9174] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 23 06 08 CMC Certification 2B 06 15 Authority id-kp-cmcCA 1.3.6.1.5.5.7.3.27 01 05 [RFC 6402] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 1B 06 08 CMC Registration 2B 06 16 Authority id-kp-cmcRA 1.3.6.1.5.5.7.3.28 01 05 [RFC 6402] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 1C 06 08 2B 06 17 CMC Archive Server id-kp-cmcArchive 1.3.6.1.5.5.7.3.29 01 05 [RFC 6402] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 1D 06 08 CMC Key Generation 2B 06 18 Authority id-kp-cmKGA 1.3.6.1.5.5.7.3.32 01 05 [RFC 9480] [RFC-ietf-cose-cbor-encoded-cert-21] 05 07 03 20 19 Unassigned 06 09 2B 06 20 Wi-SUN FAN Device id-kp-wisun-fan-device 1.3.6.1.4.1.45605.1 01 04 [RFC-ietf-cose-cbor-encoded-cert-21] 01 82 E4 25 01 21-32767 Unassigned 32768-65535 Reserved for [RFC-ietf-cose-cbor-encoded-cert-21] Private Use 65536-9223372036854775807 Reserved for Future [RFC-ietf-cose-cbor-encoded-cert-21] Use C509 General Names Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Name Comments GeneralNameValue Reference -32768 to -4 Unassigned -3 otherName with MACAddress 12 id-on-MACAddress (1.3.6.1.5.5.7.8.12) 06 08 2B bytes [RFC-ietf-cose-cbor-encoded-cert-21] 06 01 05 05 07 08 0C -2 otherName with SmtpUTF8Mailbox [RFC 9598] id-on-SmtpUTF8Mailbox text [RFC-ietf-cose-cbor-encoded-cert-21] (1.3.6.1.5.5.7.8.9) 06 08 2B 06 01 05 05 07 08 09 -1 otherName with hardwareModuleName [RFC 4180] id-on-hardwareModuleName [~oid, bytes] [RFC-ietf-cose-cbor-encoded-cert-21] (1.3.6.1.5.5.7.8.4) 06 08 2B 06 01 05 05 07 08 04 0 otherName [RFC 5280] [~oid, bytes] [RFC-ietf-cose-cbor-encoded-cert-21] 1 rfc822Name [RFC 5280] text [RFC-ietf-cose-cbor-encoded-cert-21] 2 dNSName [RFC 5280] text [RFC-ietf-cose-cbor-encoded-cert-21] 3 Unassigned 4 directoryName [RFC 5280] Name [RFC-ietf-cose-cbor-encoded-cert-21] 6 uniformResourceIdentifier [RFC 5280] text [RFC-ietf-cose-cbor-encoded-cert-21] 7 iPAddress [RFC 5280] bytes [RFC-ietf-cose-cbor-encoded-cert-21] 8 registeredID [RFC 5280] ~oid [RFC-ietf-cose-cbor-encoded-cert-21] 9-32767 Unassigned C509 Signature Algorithms Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Name Identifiers OID Parameters DER Comments Reference -32768 Unassigned to -257 30 0D 06 09 2A 86 RSASSA-PKCS1-v1_5 sha1-with-rsa-signature, 48 -256 with SHA-1 sha1WithRSAEncryption, 1.2.840.113549.1.1.5 NULL 86 [RFC-ietf-cose-cbor-encoded-cert-21] sha-1WithRSAEncryption F7 0D 01 01 05 05 00 30 09 06 07 2A See -255 ECDSA with SHA-1 ecdsa-with-SHA1 1.2.840.10045.4.1 Absent 86 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] 48 Section 3.2.2] CE 3D 04 01 -254 to Unassigned -1 30 0A 06 08 2A See 0 ECDSA with ecdsa-with-SHA256 1.2.840.10045.4.3.2 Absent 86 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] SHA-256 48 Section 3.2.2] CE 3D 04 03 02 30 0A 06 08 2A See 1 ECDSA with ecdsa-with-SHA384 1.2.840.10045.4.3.3 Absent 86 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] SHA-384 48 Section 3.2.2] CE 3D 04 03 03 30 0A 06 08 2A See 2 ECDSA with ecdsa-with-SHA512 1.2.840.10045.4.3.4 Absent 86 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] SHA-512 48 Section 3.2.2] CE 3D 04 03 04 30 0A 06 08 2B See 3 ECDSA with id-ecdsa-with-shake128 1.3.6.1.5.5.7.6.32 Absent 06 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] SHAKE128 01 Section 3.2.2] 05 05 07 06 20 30 0A 06 08 2B See 4 ECDSA with id-ecdsa-with-shake256 1.3.6.1.5.5.7.6.33 Absent 06 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] SHAKE256 01 Section 3.2.2] 05 05 07 06 21 30 0A 06 08 2B 5 Unsigned id-alg-unsigned 1.3.6.1.5.5.7.6.36 Absent 06 bytes of size 0 [RFC-ietf-cose-cbor-encoded-cert-21] 01 05 05 07 06 24 6-7 Unassigned 30 0A 06 08 2A See 8 SM2 with SM3 sm2-with-sm3 1.2.156.10197.1.501 Absent 81 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] 1C Section 3.2.2] CF 55 01 83 75 9-11 Unassigned 30 05 06 12 Ed25519 id-Ed25519, id-EdDSA25519 1.3.101.112 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] 2B 65 70 30 05 06 13 Ed448 id-Ed448, id-EdDSA448 1.3.101.113 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] 2B 65 71 30 0A 06 08 2B Proof-of-possession algorithm, 14 PoP with SHA-256 sa-ecdhPop-sha256-hmac-sha256 1.3.6.1.5.5.7.6.26 Absent 06 indexed with KDF and MAC, see [RFC [RFC-ietf-cose-cbor-encoded-cert-21] and HMAC-SHA256 01 6955]. Requires recipient's public 05 static Diffie-Hellman key 05 07 06 1A 30 0A 06 08 2B Proof-of-possession algorithm, 15 PoP with SHA-384 sa-ecdhPop-sha384-hmac-sha384 1.3.6.1.5.5.7.6.27 Absent 06 indexed with KDF and MAC, see [RFC [RFC-ietf-cose-cbor-encoded-cert-21] and HMAC-SHA384 01 6955]. Requires recipient's public 05 static Diffie-Hellman key 05 07 06 1B 30 0A 06 08 2B Proof-of-possession algorithm, 16 PoP with SHA-512 sa-ecdhPop-sha512-hmac-sha512 1.3.6.1.5.5.7.6.28 Absent 06 indexed with KDF and MAC, see [RFC [RFC-ietf-cose-cbor-encoded-cert-21] and HMAC-SHA512 01 6955]. Requires recipient's public 05 static Diffie-Hellman key 05 07 06 1C 17-22 Unassigned 30 0D 06 09 2A 86 RSASSA-PKCS1-v1_5 48 23 with SHA-256 sha256WithRSAEncryption 1.2.840.113549.1.1.11 NULL 86 [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 01 0B 05 00 30 0D 06 09 2A 86 RSASSA-PKCS1-v1_5 48 24 with SHA-384 sha384WithRSAEncryption 1.2.840.113549.1.1.12 NULL 86 [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 01 0C 05 00 30 0D 06 09 2A 86 RSASSA-PKCS1-v1_5 48 25 with SHA-512 sha512WithRSAEncryption 1.2.840.113549.1.1.13 NULL 86 [RFC-ietf-cose-cbor-encoded-cert-21] F7 0D 01 01 0D 05 00 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 01 05 SHA-256, 00 RSASSA-PSS with MGF-1 with A1 26 SHA-256 rsassa-pss, id-RSASSA-PSS 1.2.840.113549.1.1.10 SHA-256, 1C [RFC-ietf-cose-cbor-encoded-cert-21] saltLength 30 = 32 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 01 05 00 A2 03 02 01 20 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 02 05 SHA-384, 00 RSASSA-PSS with MGF-1 with A1 27 SHA-384 rsassa-pss, id-RSASSA-PSS 1.2.840.113549.1.1.10 SHA-384, 1C [RFC-ietf-cose-cbor-encoded-cert-21] saltLength 30 = 48 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 02 05 00 A2 03 02 01 30 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 03 05 SHA-512, 00 RSASSA-PSS with MGF-1 with A1 28 SHA-512 rsassa-pss, id-RSASSA-PSS 1.2.840.113549.1.1.10 SHA-512, 1C [RFC-ietf-cose-cbor-encoded-cert-21] saltLength 30 = 64 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 03 05 00 A2 03 02 01 40 30 0A 06 08 2B 29 RSASSA-PSS with id-RSASSA-PSS-SHAKE128 1.3.6.1.5.5.7.6.30 Absent 06 [RFC-ietf-cose-cbor-encoded-cert-21] SHAKE128 01 05 05 07 06 1E 30 0A 06 08 2B 30 RSASSA-PSS with id-RSASSA-PSS-SHAKE256 1.3.6.1.5.5.7.6.31 Absent 06 [RFC-ietf-cose-cbor-encoded-cert-21] SHAKE256 01 05 05 07 06 1F 31-32767 Unassigned C509 Public Key Algorithms Expert(s) Unassigned Reference [RFC-ietf-cose-cbor-encoded-cert-21] Available Formats [IMG] CSV Range Registration Procedures -32768 to -25 Expert Review -24 - 23 IETF Review with Expert Review 24 to 32767 Expert Review Value Name Identifiers OID Parameters DER Comments Reference -32768 Unassigned to -1 30 0D 06 09 2A 86 48 subjectPublicKey encoded as in 0 RSA rsaEncryption 1.2.840.113549.1.1.1 NULL 86 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] F7 Section 3.2.1] 0D 01 01 01 05 00 30 13 06 07 2A 86 48 CE 3D subjectPublicKey encoded as in EC Public Key ecPublicKey, namedCurve = secp256r1 02 [RFC-ietf-cose-cbor-encoded-cert-21, 1 (Weierstrass) id-ecPublicKey 1.2.840.10045.2.1 (1.2.840.10045.3.1.7) 01 Section 3.2.1]. Also known as P-256, [RFC-ietf-cose-cbor-encoded-cert-21] with secp256r1 06 ansip256r1, prime256v1 08 2A 86 48 CE 3D 03 01 07 30 10 06 07 2A 86 48 EC Public Key CE subjectPublicKey encoded as in 2 (Weierstrass) ecPublicKey, 1.2.840.10045.2.1 namedCurve = secp384r1 3D [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with secp384r1 id-ecPublicKey (1.3.132.0.34) 02 Section 3.2.1]. Also known as P-384, 01 ansip384r1 06 05 2B 81 04 00 22 30 10 06 07 2A 86 48 EC Public Key CE subjectPublicKey encoded as in 3 (Weierstrass) ecPublicKey, 1.2.840.10045.2.1 namedCurve = secp521r1 3D [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with secp521r1 id-ecPublicKey (1.3.132.0.35) 02 Section 3.2.1]. Also known as P-521, 01 ansip521r1 06 05 2B 81 04 00 23 4-5 Unassigned 30 13 06 07 2A 86 48 CE 3D EC Public Key ecPublicKey, namedCurve = sm2p256v1 02 subjectPublicKey encoded as in 6 (Weierstrass) id-ecPublicKey 1.2.840.10045.2.1 (1.2.156.10197.1.301) 01 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with sm2p256v1 06 Section 3.2.1] 08 2A 81 1C CF 55 01 82 2D 7 Unassigned 30 05 X25519 06 8 (Montgomery) id-X25519 1.3.101.110 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] 2B 65 6E 30 05 X448 06 9 (Montgomery) id-X448 1.3.101.111 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] 2B 65 6F 10-11 Unassigned 30 05 Ed25519 id-Ed25519, 06 12 (Twisted id-EdDSA25519 1.3.101.112 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] Edwards) 2B 65 70 30 05 id-Ed448, 06 13 Ed448 (Edwards) id-EdDSA448 1.3.101.113 Absent 03 [RFC-ietf-cose-cbor-encoded-cert-21] 2B 65 71 14-23 Unassigned 30 14 06 07 2A 86 48 CE 3D EC Public Key namedCurve = 02 subjectPublicKey encoded as in 24 (Weierstrass) ecPublicKey, 1.2.840.10045.2.1 brainpoolP256r1 01 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with id-ecPublicKey (1.3.36.3.3.2.8.1.1.7) 06 Section 3.2.1] brainpoolP256r1 09 2B 24 03 03 02 08 01 01 07 30 14 06 07 2A 86 48 CE 3D EC Public Key namedCurve = 02 subjectPublicKey encoded as in 25 (Weierstrass) ecPublicKey, 1.2.840.10045.2.1 brainpoolP384r1 01 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with id-ecPublicKey (1.3.36.3.3.2.8.1.1.11) 06 Section 3.2.1] brainpoolP384r1 09 2B 24 03 03 02 08 01 01 0B 30 14 06 07 2A 86 48 CE 3D EC Public Key namedCurve = 02 subjectPublicKey encoded as in 26 (Weierstrass) ecPublicKey, 1.2.840.10045.2.1 brainpoolP512r1 01 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with id-ecPublicKey (1.3.36.3.3.2.8.1.1.13) 06 Section 3.2.1] brainpoolP512r1 09 2B 24 03 03 02 08 01 01 0D 30 15 06 07 2A 86 48 CE 3D 02 EC Public Key ecPublicKey, namedCurve = FRP256v1 01 subjectPublicKey encoded as in 27 (Weierstrass) id-ecPublicKey 1.2.840.10045.2.1 (1.2.250.1.223.101.256.1) 06 [RFC-ietf-cose-cbor-encoded-cert-21, [RFC-ietf-cose-cbor-encoded-cert-21] with FRP256v1 0A Section 3.2.1] 2A 81 7A 01 81 5F 65 82 00 01 28-32767 Unassigned Licensing Terms